Problem solve Get help with specific problems with your technologies, process and projects.

1903 Hyper-V Networking Interference?

Yesterday, in the wake of the August 13 KB4512508 update, I noticed some of my local PCs were devoid of Internet access. Upon further investigation, I discovered a few things. First, only wirelessly connected PCs fell prey. Second, only PCs that had Hyper-V enabled were off the Internet. Third, by uninstalling Hyper-V, those PCs immediately resumed their Internet connections. Apparently, the latest CU disturbed my local network topology. Because removing Hyper-V fixed the problem I wrote it off to 1903 Hyper-V networking interference. What was going on, really?

Undoing 1903 Hyper-V Networking Interference

Armed with this knowledge, I had to step through Hyper-V configuration one more time. On my trusty Lenovo X380, I turned Hyper-V back on. This time, wireless Internet access kept working. I noticed that the Default Switch was set up automatically as its name indicates, and that it worked properly. On my previous installation, I’d set up a new and separate virtual switch. And this time around, as soon as I set up a test virtual switch named Hyper-V WLAN Switch (see below), Internet access immediately vanished.

1903 Hyper-V Networking Interference.newswitch

A new switch definition explicitly targets the Wireless NIC for network access
[Click image for full-sized view.]

The proper connection type is indeed “External network,” but the resulting network is labeled Public. Consequently, Internet access vanishes. That’s because the network topology changes. I had to go into my VM settings, and change the Network Adapter to point to the proper virtual switch. I selected “Hyper-V WLAN Switch” from the pull-down menu under the “Virtual switch” item. That did the trick!

As soon as I picked the right “NIC” (virtual switch, actually), LAN access expanded to include the Internet.

Apparently something in the latest update reset the Network Adapter as “Not connected.” As soon as I pointed to my new virtual switch, everything went back to normal. Go figure! Not a difficult fix, but upsetting to have it affect multiple desktops at the same time. One might be happenstance or coincidence; multiples is a conspiracy. That said, I’m glad it’s fixed.

Start the conversation

Send me notifications when other members comment.

Please create a username to comment.

-ADS BY GOOGLE

SearchVirtualDesktop

SearchWindowsServer

Close